How to Resolve No Water Flow At All on Profitec Pro 300

Troubleshoot no water flow on Profitec Pro 300.

No Water Flow At All on Profitec Pro 300

If there is no water flowing from your Profitec Pro 300 espresso machine, refer to the instructions below on how to properly diagnose the cause to get your machine running again.

If the pump runs, and no water is coming out, make sure that the water tank is seated properly into the socket on the water res support.

  • Remove the water softener if you are using one. Old filters can get mucky and may need to be re-filtered, or may need to be replaced. Try running the machine without a filter.
  • We can try force-priming the machine. Remove the cover for the water res and remove the water res as well. The upper cup warmer is held in by 4 2.5mm screws. Two are in the front two corners of the upper cup warmer as well as in the rear two corners. Once the top is removed looking down into the machine you will find a total of 2 3mm screws, one on each side that hold the sides of the housing in place. These can be a little difficult to remove due to it being so close to the housing that it does not leave a lot of room for your tool. Once those are removed, rest the machine on its back on a towel or pad and you will find 4 3 mm screws. These 4 hold the bottom of the housing to the frame of the machine. Once removed the machine can be returned to the upright position. In the “L” like section of the sides of the housing there is a screw with a brass bushing. This slides into the frame and holds the housing in place. There is also a metal tab that holds the housing to the front of the frame. Tap down on the top of the housing with your hand until it drops down, and pull the side of the housing outward away from the machine. You may have to wiggle it a bit as you do this, to free the brass bushing from the channel it sits in in the frame. Once this has popped out you can work the metal tab out of its position against the frame. Repeat this for the other side. Once both sides are free, slightly pull the housing sides outward away from the machine and slide it back off of the machine.
  • Looking at the back of the machine, you will see the water reservoir support. Inspect the plastic socket to make sure there is no damage. Look inside the socket where you will find a plastic shaft that runs through the center of it. This is a molded piece of the socket that when the tank is inserted the shaft pushes on a ball bearing in the valve of the water reservoir and allows water to escape the tank into the socket. If this plastic shaft is broken or bent to the side, it will not make contact and not allow water to be drawn in. Make sure the socket itself is intact. Sometimes during shipping, aging, or someone pushing far too hard with the tank, the socket will snap, leaving only the top if it secured to the reservoir support, giving the illusion the socket is there, so when the water tank is inserted it just rests inside the remaining, broken portion of the socket.
  • Inspect the water line coming off of the socket, this should have no kinks in it. If the water line is kinked it will prevent any water from being drawn in. If the water line is fine, then we can try priming the pump. Using either a prime ball or a turkey baster, fill it with water, disconnect the waterline from the socket, insert the prime ball/turkey baster into the waterline, turn the machine on and lift the lever, while the pump is running, squeeze the prime ball/turkey baster. If you feel a small amount of resistance and then the water starts going through with ease, you should be fine to put the waterline back onto the socket. Insert the water tank, and try running the pump again while watching the water level in the tank. You should be able to see the level going down if the pump is now drawing water. At this point you will be able to put the panels back on the machine. If there is resistance and the water is not going through, either the pump is very locked up, or there is a blockage in the system and may need to be serviced.

Flip the brew toggle switch. Can you hear the pump?

  • If No, try the following:
    • If the pump does not come on, try to listen to see if you can hear a slight hum. If the pump is displaying a low frequency hum it is either under pressure due to a blockage, or the pump is faulty.
    • If the pump does not activate at all it could be an issue with the brew toggle switch, a wire has come off the switch, a wire has come undone from the pump, or there is an electrical issue with the machine maybe due to a faulty control board.
    • Also check to make sure that the machine is able to sense the tank is full and in place. If the light is not activated to represent this, then look towards the above section for troubleshooting the tank.
  • If Yes, refer to this article for further instructions.
Was this article helpful?
0 out of 0 found this helpful