๐Ÿ“น How to Resolve No Water Flow At All From The Group on Profitec Pro 500 PID

Troubleshoot no water flow at all on the Profitec Pro 500 PID.

No Water Flow At All From The Group

If you arenโ€™t able to get water to flow from the group of your Profitec Pro 500 PID espresso machine, there may be a blockage in the water flow from your reservoir to your boiler. The instructions below will help you determine the cause to correct the issue.

Are you using a water softener?

  • Yes, remove it so you can test water flow without it.
    • Make sure it is not floating and sucking in air.
    • If it's old, replace it.
  • Lift the lever. Can you hear the sound of the pump?
    • Yes.
      • Open the hot water valve. Does the pump refill the boiler?
        • Yes.
          • Remove the nut at the top of the group head and check the valve. It is sometimes called a mushroom valve or jet. Inspect this for any scale or mineral deposits. Clean it really well. Hold it up to a window or a light to make sure that the hole is clear of any scale or minerals. The top of the group head when removed is one piece and to gain access to the jet and the screen the two pieces have to be separated, inside the cap is where the jet and the screen sit. If no improvement, move on to the next step.
          • While you have this out, check and see if water is sitting in the group head. This would indicate that water is at least making it out of the brew boiler and into the group head.
          • Remove the shower screen. Hold it up to a light, and see if all of the holes are clear. Soak the screen in Cafiza, or purchase a new screen and replace it.
          • With the screen removed, remove the jet breaker behind it. This will be flat and can be removed with a flathead, or it will have a bolt and will require a 19mm wrench to remove. This should be inspected for any build up that will block it off.
          • If neither of the above solutions have fully restored the water flow to the group, try doing a full group head teardown.
    • No. Is the back of the lever pressing on the microswitch?
      • No. Press it manually. Is the pump coming on now?
        • Yes. Adjust the microswitch so that it sticks out of the front further, so when lifting the lever, it can reach this button, and press down on it.
        • No. Remove the housing and look at the microswitch, inspect the wires to make sure they are not disconnected or damaged. Test continuity on the switch. Is there continuity?
          • Yes. Itโ€™s possible its a bad pump
          • No. Replace the microswitch.

Was this article helpful?
0 out of 0 found this helpful