📹 How to Resolve No Water Flow at All on Profitec Pro 500 PID

Troubleshoot no water flow on your Profitec Pro 500 PID.

There Is No Water Flow at All

If water isn’t flowing from your Profitec Pro 500 PID, there may be a problem with the pump. Refer to the instructions below to determine if there is an issue with the pump in your machine.

  • Lift the lever. Can you hear the pump?
    • No. If the pump does not come on, manually use something to push in the switch behind the brew lever. Can you hear the pump now?
      • Yes. Adjust the microswitch behind the lever so it protrudes more, and the lever can reach it when it’s pressing down on it. 
    • Yes. Please refer to this article.
    • If the machine is not drawing any water, the back panel of the machine should be removed. The plastic socket that the water reservoir slides into should be inspected. On the inside of the socket is a plastic post that runs through it that pushes the ball bearing in the reservoir valve upwards, allowing water to come through the tank into the socket. The post should be inspected to make sure it is not broken or bent. The socket should be inspected to make sure it is intact and not broken in anyway. This is common due to shipping damage or age, pushing down too hard with the water tank.
      • If the socket is fine, the water lines coming off the socket should be looked at to make sure they are not kinked shut. If the water line is kinked shut, no water will come through to the pump, or be able to be forced through via priming.
  • If the socket and water lines are fine, you can remove the waterline coming off of the pump and try running the pump to see if water comes through. If it does not, this means either the pump or the pump motor is faulty or seized. If water does come through, then this could be a sign of a bad solenoid or a blockage in the hydraulic system.

Was this article helpful?
1 out of 1 found this helpful