How to Resolve the Pump Running Continuously when the Quick Mill Arnos is Turned On

Troubleshoot continuously running pump on Quick Mill Arnos.

The Pump Runs Continuously When the Machine is Turned On

If the pump is running continuously on your Quick Mill Arnos, there may be an issue with the water sensor. Read on for instructions on how to diagnose and correct the issue.

  • This means that the steam boiler is not filling. The pump will run for about a minute and then turn off. To reset the board you will have to turn off the machine and then turn it back on. If it times out again there is a problem with the water flow.
  • If the water leaks out of the top of the boiler then the water sensing circuit is not working properly. It could be:
    • Water sensor wire came of the sensor or the board.
    • Using mineral free water. Sensors need minerals to operate. 

ADVANCED TECH ONLY

  • Remove the wire off the fill probe and ground it out. Does the pump turn off?
    • Yes. Raise the brew lever and see if water comes out of the brew group. If it does we know the pump and water circuit is working fine. The problem is probably in the steam boiler fill solenoid valve. It may be blocked or stuck.
    • No. Check the wire leading to the probe and make sure it is on the board and has continuity. If the wire is fine it may be the board.
  • If the autofill turns on after removing the wire from the probe, the boiler may already be full.
  • In very rare cases, an older machine with bad water and terrible maintenance will build scale up on the probe in the boiler, scale is a poor conductor and can cause issues with the autofill circuit functioning properly. Also make sure the connector is tight on the water level probe, if itโ€™s too loose, use a pair of pliers to tighten the connector more. You can remove the water level probe and check it for scale. If scale is present you can use fine-grit sandpaper to remove it.
Was this article helpful?
0 out of 0 found this helpful