How to Resolve Brew Boiler Not Heating or Cold Water Coming from the Group on the Profitec Pro 600

Troubleshoot brew boiler not heating or having cold water from Profitec Pro 600 group.

My Brew Boiler Is Not Heating/Cold Water Comes through the Group

If the brew boiler in your Profitec Pro 600 is not heating or cold water is coming through your brew group, there may be an issue with the high limit switch, which can be resolved by resetting or replacing it. Learn more about the process below.

1. Has 20 minutes or so lapsed with the red light off, giving the brew boiler time to heat?

  • Yes. Move on to the next question.
  • No. Make sure the machine had had 20-30 minutes to fully come to temperature.

2.Is the PID display on?

  • No. Check for loose wires to the PID. They will run from the temperature probe on the top of the front boiler to the PID display. They are very thin wires, like speaker wires. They can come loose, or break. Inspect for any damage, and make sure they are tight in the PID.
  • Yes. Move on to the next question.

3. Is the PID displaying numbers?

  • Yes. The numbers have not been rising. They seem to be stuck at a room temperature setting.
    • If the display is on, and the machine has been sitting for an adequate amount of time without rising, this indicates a heating issue with the brew boiler. Continue on to next question. This could either be a result of the high limit being popped, power not being supplied to the element, or a bad element.
  • Yes. The numbers are rising and behaving normally. Move on to the next question.
  • No. If the Display is blank, Testing for voltage from the board to the PID is necessary to determine if the control board has failed, or the PID has failed.
  • Is the PID displaying any error codes?
    • Yes.
      • A1 or A3: Connection is broken, sensor has no contact. This means that the wires connecting from the PID to the brew boiler have been disconnected or damaged. This requires a visual inspection to confirm. First, turn off the machine and unplug it. The left side panel is held in by four 3mm bolts. These bolts need only to be loosened, and do not have to be completely taken out. Look towards the back of the machine where the side panel and the rear panel meet; there is a 3mm screw there. Loosen it. Follow the side panel to the front of the machine and you will find the second 3mm. It will be holding the side panel to the frame of the machine, loosen this until you can wiggle the side panel back and forth by hand. Next you can lay down a towel or a pad and rest the machine on its side. You will see the last two 3mm bolts on the underside of the machine that hold the panel. Remove these two bolts. Supporting the now loosened panel with your hand, you can flip the machine upright. Take the bottom of the panel and move it outward a bit away from the machine, slightly push back on the upper left corner of the back panel to separate it from the side panel. The last bolt holding it in place is the front bolt. This is sitting in a little channel within the frame. If you loosened it enough, you should be able to slide the panel down and then push towards the back of the machine, and the panel will come right off. Sometimes, if the bolt is not loose enough or if there are imperfections from manufacturing, the bolt can get hung up. You can take your hand and lightly tape down on the upper corner closest to you, and then lightly tap it towards the back of the machine to slide it out of the channel in the frame it rests in. Now, look inside and locate the PID. It is the light-grey box between the front of the machine and the brew boiler. Wires run from the PID to the top of each boiler's temperature probes. Starting from the top of the brew boiler (the closest boiler in this case), black wires run to the PID where black connects link up to multi-colored wires. Check to see if the black wires are connected to the black connectors, or if they are damaged. If the wires are disconnected, connect them. If they are damaged, they will need to be replaced.
      • A2 or A4: Is the machine brand new, or have you been using the machine for some amount of time before the errors displayed?
        • If new (or if you've never had an issue before, and no work has been done inside the machine) - There is a fault in the machine, either in the control board, PID, static relay, one of the stats. A repair is recommended.
        • If used (or work has been done) - Try swapping the black connectors on the PID. Otherwise, a repair is recommended.
  •  
  •  
    •  
      •  

4. Is the little dot on the PID solid? Is the red light on the static relay solid?

  • When the machine is on and the steam boiler is heating, the dot on the PID display and the red dot on the static relay will be solid, they will not blink. When the steam boiler heats and the brew boiler starts to heat up, these lights will still be solid. When the brew boiler fully heats all the way, this is when the light on the static relay will be blinking as well as the dot on the PID display. Blinking on one and not the other would indicate a lack of communication between the components. If the red light is not on at all on the static relay, this would indicate either power is not being supplied to the relay, or the relay itself is not directing power and is therefore faulty, however if this is the case, chances are the brew boiler isn't at temp anyway.
Was this article helpful?
0 out of 0 found this helpful