How to Resolve Profitec Pro 800 Not Heating While Powered On

On But Not Heating

If your Profitec Pro 800 is on but not heating up to brew temperature, there are several things you can do to determine the cause. In many cases you can restore heating without sending your machine in for repair.

 

    • If the tank is empty, refill it.
    • If the tank is full, but the machine thinks the water tank is empty then the tank may not be seated correctly. Make sure there isn't anything blocking the tank from sitting flush inside the machine. Use of R/O, distilled, and zero waters will cause this sensor to malfunction, resulting in the machine thinking there is no water causing the pump not to activate.
  1. There is a loose, disconnected, or broken wire inside the machine. Remove the top of the machine and inspect the wiring.
  2. The high limit switch of the machine may have tripped.
    • Unplug the machine and make sure it is cooled down. Remove the cover of the machine.
    • Once the cover is removed look at the left hand side of the machine and you will find the electrical connections for the boiler. The high limit switches are the two white cylinders with the black push button in the center.


 
 The high-limit resets are circled in red.

    • Reset the switches by pressing on the button on each switch several times. The switch will not click or signal it has been reset, but the act of pressing it several times will reset it.
    • The outlet the machine is plugged into is not rated to handle the power draw of the machine.
Was this article helpful?
0 out of 0 found this helpful