How To Resolve No Water Flow At All From The Group on an ECM Elektronika II

I Have No Water Flow At All From The Group

If you're trying to use your ECM Elektronika II, but you find that there's no water dispensing from the grouphead, or your Elektronika II is unable to brew, review the following.

Are you using a water softener?

  • Yes. Remove it so you can test water flow without it.
    • Make sure it is not floating and sucking in air.
    • If old, replace it.
  • No. Move on to the next question.

Push one of the volumetric buttons. Can you hear the sound of the pump?

  • YesOpen the hot water valve. Does the pump refill the boiler?
    • Yes. Remove the nut at the top of the group head and check the valve. It is sometimes called a mushroom valve or jet. Inspect this for any scale or mineral deposits. Clean it really well. Hold it up to a window or a light to make sure that the hole is clear of any scale or minerals. When removed, the top of the group head when removed is one piece. To gain access to the jet and the screen, the two pieces have to be separated. Inside the cap is where the jet and the screen sit. If no improvement, move on to the next step.
      • While you have this out, check and see if water is sitting in the group head. This would indicate that water is at least making it out of the brew boiler and into the group head.
    • Remove the shower screen. Hold it up to a light, and see if all of the holes are clear. Soak the screen in cafiza, or purchase a new screen and replace it.
      • With the screen removed, remove the jet breaker behind it. This will be flat and can be removed with a flathead, or it will have a bolt and will require a 19mm wrench to remove. This should be inspected for any buildup that will block it off.
    • If the pump is running does it sound as if the pump is under pressure? Is there a reading on the brew gauge as if the machine has a backflush disc in place? The solenoid at the base of the group may be blocked off by debris or scale, or the solenoid is seized close. The solenoid should be removed and cleaned, as well as the passage on the group should be inspected for any buildup of debris.
    • If neither of the above solutions have fully restored the water flow to the group. Try doing a full group head teardown.
  • Can you hear the sound of the pump?
    • Yes. It’s possible it's a bad pump.
    • No. Follow these instructions. 
      • Test the pump for continuity.
      • Make sure there is voltage going to the pump.
      • See this machine's "Correct Low Brew Pressure" article.


How To Clean E61 Brew Group Mushroom, Jet and Top Valve

 

Was this article helpful?
0 out of 0 found this helpful